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Руководство пользователя MXview 
 
Программные продукты, описанные в данном руководстве, поставляются по лицензионному 
соглашению и могут использоваться только в соответствии с условиями этого соглашения. 
 

Авторские права 
 
Авторское право © 2017 г. MOXA Networking Co., Ltd. 
Все права защищены. 
 

Торговые марки 
 
MOXA - зарегистрированная торговая марка MOXA Inc. 
Все другие торговые или зарегистрированные марки, упомянутые в настоящем руководстве, 
принадлежат соответствующим производителям. 
 

Дополнение 
 
MOXA оставляет за собой право вносить изменения и дополнения в данное руководство без 
предварительного уведомления потребителя. 
 
Не предоставляя гарантий, данное руководство не ограничивает потребителя в решении специфических 
задач. MOXA оставляет за собой право в любое время изменять и/или модифицировать продукт и/или 
программное обеспечение, описанные в данном руководстве. 
 
Информация в данном руководстве является точной и надежной. Тем не менее, MOXA не несет 
ответственности за использование информации, содержащейся в настоящем руководстве, а также за 
любые нарушения прав третьих лиц, возникших в результате использования данной информации. 
 
Настоящее Руководство может содержать типографские ошибки. 
Информация, содержащаяся в настоящем руководстве, периодически корректируется; все изменения 
могут быть включены в новые издания настоящего руководства. 
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1) Введение 
 
Программное обеспечение Moxa для промышленных сетей – MXview – дает пользователям наглядное 
представление Ethernet-сети и позволяет настраивать и диагностировать сетевые устройства Moxa. 
MXview – это интегрированная платформа управления сетевыми устройствами Moxa, такими как 
Ethernet-коммутаторы и беспроводные точки доступа, а также другие устройства с поддержкой SNMP и 
ICMP, установленные в контролируемых подсетях. MXview гарантирует работу с любыми сторонними 
MIB-базами. Он также позволяет отслеживать переменные OID и Trap-сообщения с устройств сторонних 
производителей. Сетевые и Trap-компоненты, которые отображаются в MXview, могут управляться с 
помощью web-браузеров с локальных и удаленных рабочих мест в любое время и в любом месте. 
 
В данной главе рассмотрены следующие темы: 
 
 Работа с web-интерфейсом 
 Автоматическое обнаружение и визуализация топологии сети 
 Управление событиями 
 Настройка и управление прошивками 
 Мониторинг трафика 
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Работа с web-интерфейсом 
 
MXview использует модель «клиент-сервер». Пользователю необходимо установить сервер MXview на 
компьютер с ОС Windows, подключенный к сети/сетям, которыми он будет управлять. После установки 
MXview пользователь может управлять сетью с помощью браузеров Internet Explorer или Firefox без 
необходимости установки дополнительного программного обеспечение. 
 

Автоматическое обнаружение и визуализация топологии сети 
 
MXview обнаруживает сетевые устройства, поддерживающие протоколы SNMP или ICMP, в пределах 
настроенного диапазона сканирования. MXview может собирать информацию о топологии с устройств, 
поддерживающих протокол LLDP, и отображать топологию сети, показывая физические соединения 
между устройствами. Для устройств, поддерживающих протокол ICMP, но не поддерживающих LLDP, 
MXview, обладающая функцией автоматического создания топологии сети, может проверять тип 
подключений между устройствами с помощью алгоритмов ARP и помогает создать точные схемы 
топологии сети. Если в сети есть управляемые коммутаторы с поддержкой функции PoE, информация о 
выдаваемой мощности PoE-портов также будет автоматически визуализирована (более подробную 
информацию о визуализации PoE см. в разделе Визуализация потребления мощности PoE в главе 8). 
 

Управление событиями 
 
Для обнаружения и устранения неполадок MXview регистрирует события, которые соответствуют 
заданным условиям, таким как подключение/отключение кабеля, недоступность устройства или 
перегруженность трафика. Самые последние события будут отображены на панели управления. 
Устройства и каналы связи, которые создают отображаемые события, будут выделены разными 
цветами. Когда происходит событие, пользователи получают уведомления несколькими способами: 
SMS, электронная почта, всплывающее окно, звук или запуск внешней программы. 
 

Настройка и управление прошивками 
 
MXview предоставляет интерфейс для управления сетевыми устройствами Moxa из центра управления. 
Пользователи могут удаленно создавать резервные копии или обновлять файлы настроек, а также 
обновлять прошивку контролируемых устройств. 
 

Мониторинг трафика 
 
MXview может регистрировать характеристики сетевого трафика обнаруженных сетевых устройств. 
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2) Системные требования и 
поддерживаемые устройства 

 
 
В данной главе рассмотрены следующие темы: 
 
 Системные требования 
 Поддерживаемые устройства 
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Системные требования 
 
Системные требования к компьютеру, на который устанавливается MXview: 
 Системные требования 
Процессор Процессор dual core с частотой 2 ГГц или 

быстрее 
RAM 2 Гб или больше 
Свободное место на жёстком диске 10 Гб или больше 
Операционная система Windows XP Professional, 

Windows 7 (32/64-bit), 
Windows 8 (32/64-bit), 
Windows Server 2008 (32/64-bit), 
Windows Server 2012 (32/64-bit), 
Windows Server 2012 R2 

 

Поддерживаемые устройства 
 
 MXview поддерживает полный набор функций, таких как отображение состояния сети, 

журналирование трафика, а также управление файлами настроек и прошивок. 
 Для других устройств с протоколом SNMP MXview поддерживает стандартные функции 

управления, такие как факт установки или разрыва соединения, и прочая информация из SNMP 
MIB II. 

 MXview может отслеживать только подключение устройств, поддерживающих протокол ICMP. 
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3) Установка и резервная копия 
системы 

 
В данной главе рассмотрены следующие темы: 
 
 Процедура установки 
 Деинсталляция 
 Резервная копия системы 
 Восстановление системы 
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Процедура установки 
 

1. Запустите программу установки или вставьте диск с автоматическим запуском. 
2. Во время установки вы можете выбрать папку, в которую будет установлен MXview, и язык по 

умолчанию, или оставить настройки по умолчанию. 
3. В платной версии вам будет предложено ввести лицензионный ключ, который можно найти на 

этикетке, прикрепленной к коробке от диска. 
4. После завершения установки ярлыки для запуска сервера MXview будут созданы на рабочем 

столе и в меню «Пуск». 
 

Деинсталляция 
 

1. Зайдите в Пуск -> Панель управления (Start -> Control Panel) и выберите Установка и удаление 
программ (Add or Remove Programs). 

2. Выберите MXview. 
3. Нажмите Удалить (Remove). 

 

Резервная копия системы 
 
Чтобы создать резервную копию базы данных и настроек системы, используйте Project  -> Database 
Backup для сохранения файлов резервных копий. Появится окно запуска резервного копирования 
(Backup startup). 
 
Система экспортирует резервную копию базы данных в папку.  Используйте следующую ссылку, чтобы 
попасть в папку: 
 
%MXviewPro_Data%\db_backup 
 
В списке Recent Events появится событие Database backup completed. Щелкните правой кнопкой мыши 
на событии, чтобы посмотреть детали, в том числе путь к файлу резервной копии. 
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В папке с резервными копиями используется следующий способ присвоения имен:  
YYYYMMDD HHMMSS 
 
Элементы, включенные в резервную копию системы, перечислены ниже: 
 Топология 
 Трафик 
 Доступность 
 Событие 
 Настройки порога 
 Настройки диспетчера заданий 
 Элементы OID 
 Элементы Trap 
 Системные настройки 

 

Восстановление системы 
 

MXview версий 2.2 и выше поддерживают резервное копирование файлов настроек с 
расширением файлов *db3. Чтобы восстановить настройки системы из файла резервной копии, 
сначала отключите MXview. Затем в меню Пуск - > Все программы -> Moxa -> MXview -> DB 
Restore tool (Start -> All Programs -> Moxa -> MXview -> DB Restore tool) выберите DB Restore tool. 
Войдите в систему, используя свое имя пользователя и пароль. Затем укажите, где находятся 
файлы резервных копий: (1) архивный репозиторий MXview, или (2) назначенная пользователем 
папка. Укажите папку, в которой находятся файлы резервных копий, а затем нажмите кнопку 
Restore. MXview восстановит файлы резервных копий. 
 

http://www.moxa.ru/
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Поэтапная иллюстрация процесса: 
1. Зайдите в Пуск - > Все программы -> Moxa -> MXview -> DB Restore tool (Start -> All 

Programs -> Moxa -> MXview -> DB Restore tool). 

 
2. Войдите в систему, используя свое имя пользователя и пароль. 

 
3. Затем укажите, в какой папке находятся файлы резервных копий. 

 
4. Нажмите Restore. 
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MXview версий 2.1 и более ранних используют расширение *.dat для файлов резервных копий. 
Чтобы восстановить системную базу данных и настройки с помощью файла .dat, используйте 
Project -> Import MXview Configuration file, а затем выберите файл резервной копии для 
восстановления. 
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4) Начало работы 
 
 
В данной главе рассмотрены следующие темы: 
 
 Запуск сервера MXview 
 Авторизация 
 Сообщения о входе в систему 
 Аккаунт 
 Политика паролей 
 Автоматическая установка среды исполнения (среда исполнения Java) 
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MXview реализован как web-сервер для удаленного управления сетью через единый портал. На 
следующем рисунке показана рабочая схема. 

 
 
Сервер MXview работает в фоновом режиме на ПК с ОС Windows и взаимодействует с сетевыми 
устройствами с протоколом SNMP (Simple Network Management Protocol) и частным протоколом 
Moxa, который периодически опрашивает конкретные MIB-данные и сохраняет их в локальной 
базе данных. 
 
Клиент MXview использует web-браузер для предоставления сетевым операторам единого web-
интерфейса, который позволит им получить доступ и работать с MXview через локальные сети или 
Интернет. 
 

Запуск сервера MXview 
 
Для запуска сервера MXview дважды кликните ярлык MXview на рабочем столе. Когда откроется 
окно MXview (скриншот ниже), настройте порт listening сервера (или оставьте его значение по 
умолчанию 80) и посмотрите информацию о времени выполнения. Сервер запустится после 
нажатия кнопки Start. 
 
Клиент MXview на локальном компьютере запускается после нажатия кнопки Launch Client. Чтобы 
узнать, как использовать клиент MXview удаленно, обратитесь к разделу «Авторизация» ниже. 
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Примечание 
Рекомендуется выбрать Connect to MXview with Built-in Browser. 
 

Авторизация 
 
Чтобы запустить клиент MXview, откройте web-браузер и введите IP-адрес или доменное имя 
сервера MXview в поле адреса. Помните, что если порт listening сервера изменяется, необходимо 
ввести IP-адрес следующим образом: http://[IP address]:[Port] (e.g. http://192.168.1.250:8080). Если 
в качестве клиента используется серверный компьютер, вы также можете нажать Launch Client на 
панели управления. Имя пользователя по умолчанию – admin. Для MXview версии 2.6 и более 
ранних пароль по умолчанию пустой. Для MXview версии 2.7 и выше пароль по умолчанию – 
moxa.  
 

 
 
 
Примечание 
В систему одновременно могут войти не более 10 пользователей. 
 
 
Примечание 
Для удаленных пользователей рекомендуется загрузить “MXviewClient” с сервера MXview и 
использовать его для входа в систему. 
 

Сообщения о входе в систему 
 

1. Зайдите в раздел Project -> Preferences -> Login Notification. 
2. Пользователи могут установить свое сообщение об ошибке авторизации в системе и 

подтверждение авторизации входа. 
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Аккаунт 
 
Существует три учетных записи по умолчанию (admin, user и guest) с разными правами доступа 
(администратор и пользователь), как показано ниже.  
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Имя пользователя по 
умолчанию 

Пароль по умолчанию Права доступа 

admin moxa Администратор 
user --- Пользователь 
guest --- Пользователь 
 
«Администратор» может изменять настройки MXview, такие как топология и диапазон 
сканирования. «Пользователь» есть права только на чтение. Для версии MXview 2.7 и выше 
аккаунты может быть созданы, изменены и удалены, а права доступа могут быть расширены. 
 
Примечание 
Может быть создано до 100 аккаунтов. 
 

Политика паролей 
 

1. Зайдите в раздел Project -> Preferences -> Password Policy. 
2. В Account Password Policy пользователи могут устанавливать минимальную длину и 

степень сложности пароля. 
3. В Account Login Failure Lockout пользователи могут установить порог повторной попытки и 

время блокировки. 
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Автоматическая установка среды исполнения (Java 
Runtime Environment) 
 
Клиент MXview должен быть запущен в среде JRE (Java Runtime Environment). Пользователям, у 
которых нет соответствующей версии JRE, MXview поможет установить соответствующую версию 
автоматически. 
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5) Быстрый запуск с мастером 
установки 

 
 
MXview предлагает мастер установки, который можно использовать для быстрого определения 
топологии сети и выполнения основных настроек. 
 
В данной главе рассмотрены следующие темы: 
 
 Использование мастера установки 

 Шаг 1: Создание группы 
 Шаг 2: Настройка строки SNMP Community 
 Шаг 3: Добавьте сети, которые хотите сканировать 
 Шаг 4: Нарисуйте топологию 
 Шаг 5: Установите сервер SNMP Trap для получения событий в режиме реального 
времени 

 Виртуальная демо-сеть 
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Использование мастера установки 
 
Мастер установки запускается автоматически, если в ПО не настроено никаких устройств для 
мониторинга. Чтобы запустить мастер установки вручную, выберите Project -> Wizard. Откроется 
следующее окно: 
 

 
 
Мастер установки проведет вас через пять основных шагов, описанных ниже. 
 

Шаг 1: Создание группы 
 
MXview просканирует устройства и организует их в многоуровневую структуру. Перед поиском 
устройств необходимо создать группы. Root – единственная группа по умолчанию. Все остальные 
созданные группы помещаются в подгруппы Root. 
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Шаг 2: Настройка строки SNMP Community 
 
MXview использует SNMP для сбора информации об устройствах. Настройки SNMP по умолчанию: 

• Версия: v1 
• Права доступа на чтение: public 
• Права доступа на запись: private 

 
При необходимости обновите эту информацию в этом окне: 
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Шаг 3: Добавьте сети, которые хотите сканировать 
 
Работа MXview основана на протоколе IP (Internet Protocol). Устройства, расположенные в 
диапазоне сканирования и использующие для работы IP-протокол, будут обнаружены и 
отображены в MxView. 
 

 
 
Нажмите Add Network, чтобы добавить диапазон сети для сканирования. Откроется окно с двумя 
вкладками: Single Range и Multiple Ranges.  
 
Single Range: Введите первый и последний IP-адрес в желаемом диапазоне. Назовите этот 
диапазон в поле Name. 
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Multiple Ranges: Вкладка Multiple Ranges позволяет настроить сложную подсеть для сканирования. 
Выберите enable для назначения диапазона подсети, аналогично – с используемой маской 
подсети. Вы можете указать диапазон сканирования так же, как на вкладке Single Range. 
 

 
 
Другой способ сканирования сети – импортировать список устройств. Нажмите Import Device List и 
выберите файл со списком для загрузки в MXview.  
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Примечание 
IP-адрес устройства должен быть настроен должным образом до того момента, когда им нужно 
будет управлять с помощью MXview. 
 
На этом этапе MXview войдет в режим поиска устройств. Время, необходимое для завершения 
этого этапа, зависит от размера диапазона сканирования. Нажмите Cancel, чтобы выйти из 
мастера установки; однако настройки, введенные ранее, будут сохранены, а процесс поиска будет 
продолжать работать в фоновом режиме. 
 

 
 

Шаг 4: Нарисуйте топологию 
 
После того, как все устройства будут найдены, MXview сможет нарисовать топологию для 
устройств LLDP. 
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Для устройств без функций LLDP топология может быть нарисована вручную после завершения 
работы мастера.  
 
После того, как все устройства были обнаружены и была создана топология, нажмите Next, чтобы 
перейти к следующему шагу. 
 

 
 

Шаг 5: Установите сервер SNMP Trap для получения событий в режиме 
реального времени 
 
Чтобы включить генерацию событий в режиме реального времени, IP-адрес сервера MXview 
должен быть настроен как trap server. Для этого введите IP-адрес сервера MXview и нажмите Set, 
чтобы активировать изменение. 
 
Если этот шаг пропущен, устройства все равно могут управляться путем периодического опроса, но 
при опросе возможны задержки. 
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После этого шага инициализация MXview завершена. 
 

 
 
 
Примечание 
Для быстрого устранения неисправностей в будущем следуйте указаниям мастера установки, 
чтобы сделать снимок сети. 
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Виртуальная демо-сеть 
 
MXview позволяет создавать виртуальные демо-сети, которые могут использоваться для оценки 
многих функций MXview. Чтобы активировать виртуальную демо-сеть, запустите мастер установки 
и выберите Start Demo Network в нижней части окна. 
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Следуя мастеру установки MXview Setup Wizard, вы можете легко создать сетевую среду. 
 

 
 
После того, как мастер установки завершит свою работу, вы сможете попробовать MXview в 
виртуальной демо-сети. 
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6) Обзор приборной панели 
 
 
 
При входе в MXview появится приборная панель. При использовании MXview большую часть 
времени пользователь проводит на приборной панели, которая разделена на следующие 
разделы: 
 

1. Строка меню 
2. Карта топологии 
3. Список устройств 
4. Свойства устройства 
5. Миниатюрная карта топологии  
6. Недавние события 
7. Строка состояния 

 

 
 
В данной главе рассмотрены следующие темы: 
 
 Строка меню 
 Карта топологии 
 Список устройств 
 Свойства устройства 
 Недавние события 
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Строка меню 
 
Доступ ко всем операциям возможен из следующих пунктов меню: 
 
Project 
 
Используйте меню Project для сканирования устройств из нескольких диапазонов IP-адресов, 
добавления устройств с определенным IP-адресом, сохранения сетевых групп, настройки MXview 
или запуска мастера установки. Кроме того, вы можете создавать резервные копии данных и 
настроек отслеживаемых сетей, сохранять историю событий, создавать расписание заданий или 
импортировать файл проекта для оперативного создания наблюдаемых сетей. 
 
View 
 
Используйте меню View для изменения внешнего вида карты топологии. Например, вы можете 
настроить разрешение карты или создать новую карту топологии. 
 
Device 
 
Используйте меню Device для настройки или проверки свойств объектов. 
 
Link 
 
Используйте меню Link для удаления канала связи или получения отчета о трафике. 
 
Information 
 
Используйте меню Information для проверки всех свойств сети. 
 
Event 
 
Используйте меню Event для просмотра событий и настройки уведомлений. 
 
Tools 
 
Используйте меню Tools для запуска дополнительных сервисов или программ, например, Moxa IP 
Configurator. 
 
MIB 
 
Используйте меню MIB для сбора или просмотра сторонних MIB-файлов. Импорт сторонних OID и 
Trap возможен через диспетчер импорта OID и менеджер импорта Trap. 
 
Help 
 
Используйте меню Help для просмотра информации о лицензии или информации о MXview. 
 

Карта топологии 
 
Карта топологии отображает отношения между наблюдаемыми устройствами. Для устройств с 
поддержкой LLDP можно автоматически нарисовать линии связи. 
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Список устройств 
 
В разделе Device List отображается структура карты топологии в формате дерева. Обратите 
внимание, что информация о каналах связи не отображается. Введите имя устройства или его 
часть в поле ввода “Search Devices”, чтобы отображались только те устройства, чьи имена 
содержат это ключевое слово (например, введите “EDS”, чтобы показать все устройства EDS, или 
введите “EDS-G509”, чтобы показать все коммутаторы EDS -G509 этой сети. 
 

 
 

Свойства устройства 
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В разделе Device Properties отображаются свойства выбранного устройства. Если интерфейс 
устройства поддерживает PoE, значок интерфейса изменится на желтую молнию. 
 

 
 

Недавние события 
 
В этом списке показаны события, которые произошли совсем недавно. 
 
В разделе Event Count отображается общее количество событий с разными типами, 
идентифицированными разными цветными прямоугольниками (например, красным, желтым и 
зеленым, как показано на скриншоте ниже). 
 
All Events – кнопка в разделе меню Event -> All. Если нажать All Events, появится окно со всеми 
событиями. 
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7) Обнаружение и опрос устройств 
 
 
 
Устройства в заданном диапазоне сканирования могут быть обнаружены с помощью протоколов 
SNMP и ICMP. После обнаружения устройства MXview будет использовать SNMP и ICMP для 
периодического опроса устройства. Для правильной настройки этой функции необходимо знать 
следующую информацию: 
 

1. IP-адреса устройств сети. 
2. Имя Read Community, присвоенное устройствам сети. 

 

Изменение строки Read Community 
 
Значение строки Read Community по умолчанию, используемой для поиска устройства, - public. 
Для изменения значения выполните следующие действия: 
 

1. Зайдите в Project -> Preferences -> SNMP Configuration.  
2. Введите новую ссылку Read Community. 

 

 
 

Диапазон сканирования 
 
Пользователь может назначить несколько сканируемых сетей, границы каждой сети 
определяются начальным и конечным IP-адресом. MXview обнаружит все активные устройства, 
принадлежащие сканируемым сетям. 
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Выполните следующие шаги для добавления сканируемой сети: 
 

1. Зайдите в Project -> Scan Range. 
 

 
 

2. Нажмите Add Network. 
 

 
 

3. Введите начальный и конечный IP-адрес диапазона и нажмите OK. 
4. Нажмите OK & Discovery для запуска обнаружения. 

 
  
Примечание 
Поиск устройств потребует больше времени для больших сетей. По этой причине, если возможно, 
пользователям следует избегать больших диапазонов сканирования. 
 
При удалении сканируемой сети удаляются контролируемые устройства, входящие в эту сеть. 
Выполните следующие шаги для удаления сканируемой сети: 
 

1. Зайдите в Project -> Scan Range 
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2. Выберите строку в таблице Scan Range 
3. Нажмите Delete Network 
4. Нажмите OK для активации изменений 

 
Изменение сканируемой сети приведет к удалению устройств, не принадлежащих к новой сети, и 
обнаружению новых устройств в новой сети. Выполните следующие шаги для изменения 
сканируемой сети: 
 

1. Зайдите в Project -> Scan Range 
2. Выберите строку в таблице Scan Range 
3. Нажмите Modify Network 
4. Измените начальный и конечный IP-адреса диапазона и нажмите OK 
5. Нажмите OK для активации изменений 

 
Снятие флажка Active отсканированной сети прекратит обнаружение устройств для этой сети. 
Контроль за ранее обнаруженными устройствами будет продолжаться, а их текущее состояние 
продолжит отображаться на карте топологии. 
 

Импорт/экспорт списка устройств 
 
С помощью этой функции пользователи могут легко экспортировать любые устройства в список 
устройств, а также импортировать любой список устройств в MXview. 
 

Импорт списка устройств 
 

1. Зайдите в Project -> Import Device List 
2. Выберите список и нажмите Open 
3. Список всех устройств импортируется в MXview 
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Экспорт списка устройств 
 

1. На карте топологии выберите устройства, которые необходимо экспортировать в список. 
2. Зайдите в Project -> Export Device List 
3. Введите имя файла и нажмите Save 
4. Список устройств сохранится 

 

 
 
 
Примечание 
Список Device List можно использовать во всех программах MXstudio, включая 
MXconfig, MXview и N-Snap. 
 
 
 
MXview также отображает подробные параметры и настройки устройств, в том числе следующие: 

• MAC-адрес 
• Название устройства 
• IP-адрес 
• Маска подсети 
• Шлюз 
• Адрес Trap-сервера 
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• Автоматическая настройка IP-адресов 
• Тип протокола резервирования 
• Роль в резервированной сети 
• Состояние и свойства порта 
• Состояние питания 
• Состояние и версия протокола SNMP 

 
MXview будет использовать одну из следующих иконок для обозначения устройств: 

Устройства Moxa с поддержкой SNMP. 

 

Сторонние устройства с поддержкой SNMP. 

 

Сторонние устройства с поддержкой ICMP. 

 
 
IP-адрес и имя местоположения обнаруженного устройства будут показаны под изображением. 
Для изменения имени местоположения выполните следующие действия: 
 

1. Выберите устройство 
2. Зайдите в Device -> Maintenance -> Configure IP & SNMP 
3. Перейдите на вкладку Basic и введите новое имя 

 
MXview периодически запускает поиск новых устройств в диапазонах сканирования. Вы также 
можете использовать следующие шаги для поиска устройства вручную: 
 

1. Зайдите в project -> Scan Range 
2. Нажмите OK & Run Discovery 

 
Найденные устройства периодически будут опрашиваться по протоколам ICMP и SNMP. Это 
происходит по следующим причинам: 
 

1. Для контроля доступности устройств. 
2. Для обновления свойств и параметров настройки устройств. 
3. Для обновления информации о трафике, например, загруженности устройства. 

 

Plug-in Manager для MXview 
 
Для устройств Moxa, не поддерживающих MXview по умолчанию, вы можете добавить Plug-in Kits 
этих устройств в MXview через Plug-in Manager, и значки устройств будут отображаться на карте 
топологии (Topology Map) MXview. 
 

1. Зайдите в MXview -> Plug-in Manager for MXview в меню Пуск 
2. Введите имя пользователя и пароль 
3. На странице Plug-Ins нажмите Add и выберите папку Plug-in Kit 
4. Модели Plug-in появится в списке и добавятся в MXview 
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5. Выйдите из Plug-in Manager и войдите в систему MXview, значки устройств можно 
отобразить на карте топологии (Topology Map) 
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8) Управление топологией 
 
 
Карта топологии (Topology Map) – основа MXview, она может использоваться для выполнения 
большинства действий. Карта топологии графически отображает устройства в сетях и может 
использоваться для выполнения следующих действий: 
 

• Отображение графического представления реальной сети. 
• Визуализация связей между устройствами. 
• Демонстрация состояния устройств и каналов связи. 

 

Многоуровневая структура 
 
Карта топологии (Topology Map) может быть организована в иерархическую структуру глубиной 
до 5 уровней. Это помогает пользователям управлять большим количеством узлов на экране 
компьютера. Например, пользователи могут перемещать узлы одной подсети или изменять 
положение устройства в его же группе. Папка Root, которая является единственной группой на 
первом уровне, существует по умолчанию и не может быть удалена. Группы, созданные 
пользователями, находятся на уровнях ниже Root. Устройства могут быть перемещены из группы в 
группу. MXview использует иконки для обозначения пользовательских групп: 
 
Первый уровень: 
 

 
 
Второй уровень: 
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Карта представлена как окно с вкладками, в котором каждая вкладка представляет собой группу. 
Двойной щелчок на иконке группы в папке Root откроет соответствующую вкладку. 
 

Автоматическая прорисовка топологии и автоматическое 
создание схемы размещения 
 
Для устройств, поддерживающих протокол LLDP, MXview может отображать карту физической 
топологии, вплоть до уровня порта устройства. Для устройств без MIB-баз протокола LLDP MXview 
может рисовать каналы связи и с помощью ARP. Для активации этой функции установите флажок 
Advanced Topology Analysis. 
 
MXview может выполнять следующие задачи автоматически: (1) Создавать новые топологии, и (2) 
Обновлять существующие топологии. 
 
Создание новой топологии удаляет все каналы связи, запрашивает информацию о LLDP с 
устройств и рисует карты топологии на основе собранной информации. 
 

1. Зайдите в раздел View -> Auto Topology 
2. Выберите New Topology 
3. Нажмите OK 
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Примечание 
Каналы связи, прорисованные вручную, будут удалены этой функцией. 
 
 
Примечание 
Для использования Advanced Topology Analysis устройства должны иметь прошивку версии 3.1 
или выше.. 
 
 
Примечание 
Если функция AutoTopology не создает точное представление о реальной сети, снимите флажок 
Advanced Topology Analysis и повторите попытку. 
 
Обновление существующей топологии добавляет новые и обновляет существующие каналы связи, 
но не изменяет состояния тех каналов, которые обозначены как отключенные или были 
нарисованы вручную.  
 

1. Зайдите в раздел View -> Auto Topology 
2. Выберите Update Topology 
3. Нажмите OK 
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На следующем рисунке показан пример карты топологии: 
 

 
 
Автотопология поддерживает сторонние устройства, которые совместимы с MIB-базами 
протокола LLDP. 
 
 Устройство Moxa* Устройство 

стороннего 
производителя с 

протоколом SNMP 

IP-устройство 

Автотопология LLDP MIB 
Авто-топология на 
базе ARP 
(коммутаторы Moxa с 
версиями прошивки 
3.1) 

LLDP MIB Поддерживаются при 
условии подключения 
к коммутатору Moxa 
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Примечание 
Протокол LLDP по умолчанию включен на устройствах Moxa. Для работы функции автоматической 
прорисовки топологии, пожалуйста, не выключайте LLDP. 
 

Топологии резервирования 
 
Топологии резервирования имеют, по крайней мере, одну резервную линия связи, которая будет 
обозначена пунктирной линией: 
 

 
 
Для устройств, которые играют в топологии определенную роль, MXview будет обозначать роли 
над картинками устройств. Резервные линии связи будут обозначены пунктирными линиями. 
 

• В топологии RSTP – Root 
• В топологии Turbo Ring – Master 
• В топологии Turbo Chain – Head и Tail 

 
 
Примечание 
Пунктирные линии для резервных линий связи будут отображаться только при автотопологии. 
Резервные линии связи, нарисованные вручную, буду отображаться как сплошные. 
 

Визуализация потребления мощности PoE 
 
Благодаря периодическому опросу линии связи PoE, непосредственно на карте топологии будет 
отображаться номер порта, мощность (Вт), напряжение (В) и потребляемый ток (мА). 
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Визуализация VPN-тоннелей 
 
VPN-тоннели будет отображаться с использованием разных цветов, как показано на рисунке ниже. 
 

• Синий: Все VPN-тоннели подключены. 

 
 

• Желтый: Как минимум один VPN-тоннель отключен 

 
 

• Красный: Все VPN-тоннели отключены 

 
 
 
Примечание 
Визуализация VPN-тоннеля доступна только для серии маршрутизаторов EDR-810. 
 

Визуализация технологии PRP/HSR 
 
MXview может указывать разные роли устройств в технологии PRP / HSR, включая PRP, HSR, 
Coupling и Quadbox. Линии связи PRP/Coupling LAN A, LAN B и HSR Ring обозначаются разными 
цветами. 
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Примечание 
Визуализация PRP/HSR доступна только на устройствах серии PT-G503. 
 

Иконки устройств сторонних производителей 
 
MXview поддерживает большинство сетевых устройств, даже устройства сторонних поставщиков. 
Ниже приведен пример сети, которая включает устройства Moxa и устройство Cisco. MXview 
изменит иконку устройства, чтобы показать, что это устройство Cisco. 
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Производители, устройства которых визуализирует MXview: ABB, CISCO, Emerson, Hirschmann, 
Rockwell, Schneider и Siemens. 
 

 
 

Функция Port Trunking 
 
Функция Port Trunking, также называемая link aggregation, используется для группировки линий 
связи в группы агрегированных портов. Линии связи trunking будут обозначены сплошными 
толстыми линиями. 

 
 
 
Примечание 
Только в автотопологии можно нарисовать толстые линии для линий связи trunking. 
Нарисованные вручную будут отображены в виде сплошных линий. 
 
 
Примечание 
При создании линий связи trunking проверьте “Device Properties”, чтобы верно указать номер 
порта, соответствующий группе каналов. 
 

 
 

Добавление канала связи 
 
Для прорисовки линии связи между двумя устройствами на карте топологии используйте один из 
следующих способов: 
 

1. Щелкните правой кнопкой мыши на устройстве и выберите Add Link. 
2. Нажмите на устройство, затем в строке меню нажмите Link -> Add Link. 
3. Введите порты и IP-адреса, соответствующие линии связи. Используйте знак “+” в левом 

нижнем углу, чтобы добавить несколько за один раз. 
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Примечание 
Каналы trunking и резервированные каналы, добавленные вручную, будут отображены на карте 
сплошными линиями. 
 
 
Примечание 
Чтобы получать верную информацию о трафике, номера портов должны быть числовыми и 
введены правильно. 
 
 
Примечание 
Для модульных коммутаторов номер порта зависит от шасси, которому принадлежит порт, но не 
от количества модулей. Для таких коммутаторов, как PT-7828, номера портов первого модуля – от 
1 до 8, второго – от 9 до 16, и так далее. Номер порта зависит только от того, в каком слоте 
находится модуль; другими словами, номер порта остается неизменным вне зависимости от того, 
являются другие слоты пустыми или занятыми. 
 

Удаление канала связи 
 
Выполните следующие шаги для удаления канала связи с карты топологии: 
 

1. Выберите канал связи. 
2. Щелкните правой кнопкой мыши на нем и выберите Delete Link, или зайдите в Link -> 

Delete Link. 
 

 
 
Примечание 
При удалении канала связи, он удаляется с карты топологии, но не влияет на фактическую 
конфигурацию сети. 
 

Удаление устройства 
 
Пользователи могут удалять устройства с карты топологии. После удаления устройства, оно будет 
удалено с карты топологии и диапазона сканирования и не будет опрашиваться или 
обнаруживаться при поиске. Выполните следующие шаги для удаления устройства с карты 
топологии: 
 

1. Выберите устройство 
2. Щелкните правой кнопкой мыши на нем 
3. Выберите Delete Device 

 
Удаленные устройства будут записаны в разделе Project -> Scan Range 
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Пользователь может восстановить удаленные устройства. После восстановления устройства будут 
обнаружены при поиске и опрошены. Для восстановления удаленных устройств выполните 
следующие действия: 
 

1. Зайдите в Project -> Scan Range 
2. Выберите строку в таблице Deleted Devices 
3. Нажмите Recover, затем OK 

 

Навигация 
 
Миниатюрная карта – это карта с ползунком для регулировки разрешения большой карты. Эта 
функция помогает пользователям увеличивать/уменьшать масштаб карты, чтобы иметь 
возможность видеть больше/меньше устройств на экране. 
 

 
 

Фон карты топологии 
 
Пользователь может вставить фоновое изображение на карту топологии, чтобы иметь 
возможность видеть дополнительную информацию, такую как географическая информация или 
макет структуры. 
 
Для вставки или изменения фона выполните следующие действия: 
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1. Зайдите в View -> Set Background 
2. Выберите картинку из локальной файловой системы 

 
Для удаления фона выполните следующие действия: 
Зайдите в View -> Delete Background 
 

 
 

Экспорт топологии 
 
Карта топологии может быть экспортирована как изображение формата JPEG. Для экспорта карты 
топологии выполните следующие действия: 
 

1. Зайдите в View -> Export Topology 
2. Выберите папку, куда нужно сохранить изображение 

 

Генерация тегов OPC 
 
MXview может генерировать теги свойств устройства и каналов связи, совместимые с технологией 
OPC 2.0. OPC-клиенты, такие как SCADA-системы, смогут получать и использовать эти теги. 
 

1. Зайдите в Tools -> OPC Server 
2. Нажмите Start 
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В настоящее время по умолчанию информация, которую MXview может подготовить как теги, 
включает в себя: 
 

1. Тег Health, который представляет состояние работоспособности всей сети. 
2. IP-адрес устройства (IP address), MAC-адрес (MAC address), и состояние (status), которые 

помечены символом D_ в начале имени. 
3. IP-адреса и порты, соответствующие линии связи, которые помечены символом L_ в 

начале имени. 
 
 
Примечание 
Тег Health показывает состояние работоспособности всей сети. Существует три уровня: Normal 
(нормальный), Warning (предупреждающий) и Critical (критический), со значениями 0, 1 и 2 
соответственно. MXview позволяет пользователям использовать только один тег для контроля 
состояния всей сети. 
 
MXview также может с помощью OPC-тегов передавать все свойства из протокола SNMP в Device 
Properties List. 
 

1. Зайдите в Tools -> Custom OPC Tags 

2. Нажмите  чтобы вручную добавить свойства в список 
3. Выберите свойства в списке и нажмите Register, чтобы установить их на устройствах 
4. Появится Tag count (количество тегов) и Registered device count (количество 

зарегистрированных устройств) 
5. Нажмите OK для завершения переноса 
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Если свойства, которые вы хотите перенести, не отображаются в списке, вы можете использовать 
MXview MIB Browser для импорта MIB-файлов вручную. Затем OID Import Manager поможет вам 
импортировать переменные OID в список свойств устройств и перенести их в OPC-теги. Точно так 
же любая сторонняя MIB-база может сгенерировать свой OPC-тег. 
 
Пример: Получение информации о дальности передачи с помощью MXview OPC Server 
 
Чтобы получить информацию о дальности передачи с помощью MXview OPC Server, первым 
шагом является загрузка MIB-базы и импорт информации о расстоянии передачи данных SNMP 
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OID “devTxRange” в список свойств устройства. Затем пользователи могут легко найти свойство в 
списке и перенести его в OPC-тег. 
 

1. Зайдите в MIB -> MIB Browser 
2. Откройте File -> Load MIB 
3. Выберите SNMP MIB и добавьте его в список MIB-файлов (MIB list). 

 

 
 

4. Откройте MIB -> OID Import Manager 
5. Нажмите Add и выберите OID 
6. Назначьте эту переменную OID выбранным устройствам 
7. Новая OID появится в списке Devices Properties List 
8. Свойство “devTxRange” отобразится в списке свойств и теперь может быть перенесено в 

OPC-тег 
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9) События и уведомления 
 
 
 
 
В данной главе рассмотрены следующие темы: 
 
 Способы мониторинга 

 Мониторинг с помощью сообщений SNMP Trap 
 Мониторинг с помощью периодического опроса 
 Мониторинг с помощью цветовой маркировки 

 Завершение событий 
 Уровень угрозы 
 Настраиваемые события 
 Недавние события 
 История событий 
 Уведомления 

 Уведомление по СМС 
 Уведомление по Email 
 Уведомление по SNMP Trap 
 Уведомление на мобильный телефон 
 Звуковое уведомление 
 Уведомление с помощью внешней программы 
 Уведомление в окне сообщений 

 Событие Syslog 
 Воспроизведение сетевых событий 

 Включение режима воспроизведения 
 Вход в режим воспроизведения 
 Режим времени и режим события 
 Обзор пользовательского интерфейса воспроизведения 
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Способы мониторинга 
 
Мониторинг может проводиться с использованием сообщений SNMP trap, периодического опроса 
устройство по SNMP или по ICMP и с помощью цветовой маркировки; все способы описаны в 
следующих подразделах. 
 

Мониторинг с помощью сообщений SNMP Trap 
 
Благодаря серверу MXview в качестве получателя trap-сообщений с устройства, события, 
связанные с устройством, в режиме реального времени отправляются на сервер и отображаются 
на удаленных клиентах.  
 
Для установки получателя trap-сообщений выполните следующие действия: 
 

1. Зайдите в Tools -> Set Trap Server to All 
2. Заполните IP-адрес сервера MXview и строку Community String 

 
 
Выполните следующие действия, чтобы установить получателя trap-сообщений для одного 
устройства: 
 

1. Зайдите в Device -> Maintenance -> Configure IP & Trap 
2. Выберите вкладку Trap Server 
3. Заполните IP-адрес сервера MXview и строку Community String 
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Типы событий включают в себя link up/down порта, включение/выключение питания, изменение 
топологии и изменение настроек. 
 
Если в контролируемом устройстве корректно настроен Trap-сервер, состояние устройства будет 
автоматически контролироваться на базе информации из Trap-сообщений 
 

Мониторинг с помощью периодического опроса 
 
После обнаружения устройства MXview периодически проверяет состояние активных портов 
устройства. Имейте в виду, что поскольку trap-сообщения передаются по протоколу UDP, нет 
абсолютной гарантии того, что сообщения будут получены. Периодические опросы обеспечат 
более высокий уровень надежности для устройств мониторинга. 
 
При периодическом опросе MXview может пассивно при помощи SNMP отслеживать состояние 
устройства, загрузку канала связи, процент ошибочных пакетов и частоту коллизий. MXview также 
может активно контролировать доступность устройств с помощью опроса по ICMP. MXview 
опрашивает устройства каждые 10 секунд и вычисляет среднюю доступность в течение 24 часов. 
 
Отдельные пороги могут использоваться для проверки загруженности каналов связи, процент 
ошибочных пакетов, частоту коллизий и доступность устройств. Когда любой из этих порогов 
будет превышен, устройство покажет, что произошло событие. 
 

Мониторинг с помощью цветовой маркировки 
 
Когда происходит критическое событие на линии связи (например, обрыв канала связи), цвет 
соответствующей линии изменится: 
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Когда устройство присылает аварийное сообщение или происходит критическое событие 
(например, сбой устройства), устройство с ошибкой будет обозначено красным квадратом. 
 

 
 
Кроме того, события будут добавлены в список последних событий. 
 

 
 
 

Завершение событий 
 
События будут автоматически завершены, когда будет устранено условие, вызвавшее событие. 
 

 
 

Уровень угрозы 
 
События могут быть установлены на один из трех уровней угрозы: critical (критический), warning 
(предупреждающий) или information (информационный). Пользователь может настроить условия, 
соответствующие определенному уровню угрозы. Чтобы настроить уровни угрозы, зайдите в 
Project -> Preferences -> Events и измените настройки. 
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Настраиваемые события 
 
Используя раздел MXview Custom Events, пользователи могут определять свои собственные 
события с гибкими порогами, уровнем угрозы, описанием и продолжительностью.  
 

1. Зайдите в Event -> Custom Events 

2. Нажмите  , чтобы вручную добавить свойства в список 
3. Установите свойства Threshold Type, Threshold number, Severity, Description и Duration 
4. Выберите свойства из списка и нажмите Register, чтобы установить их на устройствах 
5. Появится окно с Tag count и Registered device count 
6. Нажмите OK и завершите настройку 
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Если события произойдут, они будут показаны в списке последних событий, а соответствующие 
устройства будут отмечены цветом. 
 

 
 
Когда свойства с произошедшим событием вернутся к нормальному состоянию, MXview покажет 
события по восстановлению в Recent Events List. 
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Примечание 
Единица измерения продолжительности событий – минута. Могут быть заданы только 
целочисленные значения. 
 

Недавние события 
 
MXview показывает последние события в нижней части приборной панели. 
 

 
 

История событий 
 
Чтобы посмотреть историю событий всех устройств, зайдите в Event -> All в строке меню. 
 
Чтобы показать историю событий одного устройства, щелкните правой кнопкой мыши устройство 
и выберите Events. 
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Таблица содержит 40 записей на странице. Используйте элементы управления внизу страницы, 
чтобы перемещаться между страницами 
 

 
 
Вы можете отсортировать таблицу, щелкнув на ячейке заголовка. 
 

 
 
Чтобы отфильтровать таблицу, используйте поле выбора ячейки заголовка и выберите значение. 
 

 
 
 
Примечание 
Функции сортировки и фильтрации влияют только на таблицы, отображенные на экране в 
настоящее время. Они не действуют на всю таблицу. Это остается неизменным, даже если в 
настоящее время отображается менее 40 записей. 
 
Вы можете экспортировать все события в CSV-файл или удалить все события из базы данных. 
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Уведомления 
 
Вы можете одновременно запустить несколько способов уведомления, например, отправить 
текстовое сообщение и электронное письмо, издать звук или запустить внешнюю программу с 
комбинацией типов событий, IP-адресов источника и уровня угрозы. 
 
Есть 7 типов уведомлений: 
 

• SMS – отправить текстовое SMS-сообщение 
• Email – отправить email 
• Program – запустить внешнюю программу 
• Sound – проиграть звуковой файл 
• Message Box – показать окно сообщения 
• SNMP Trap – отправить SNMP trap-сообщение другому SNMP trap-серверу 
• Mobile Client – отправить push-уведомление на мобильный телефон 

 

 
 
Есть 19 типов событий: 
 

• Устройство недоступно по протоколу ICMP 
• Устройство недоступно по протоколу SNMP 
• Питание выключено 
• Питание включено 
• Канал связи оборван 
• Питание изменено на постоянный ток 
• Питание изменено на переменный ток 
• Превышение порогового значения потока входящего трафика 
• Поток входящего трафика ниже порогового значения 
• Превышение порогового значения потока исходящего трафика 
• Поток исходящего трафика ниже порогового значения 
• Превышение процента ошибок входных пакетов 
• Превышение процента ошибок выходных пакетов 
• Значение доступности устройства ниже порогового 
• Происходит настроенное пользователем событие 
• Завершено настроенное пользователем событие 
• DDoS-атака на маршрутизатор 
• Атака на firewall маршрутизатора 
• Атака на маршрутизатор безопасного доступа 
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Уведомление по СМС 
 
Для отправки SMS-уведомлений, в первую очередь подключите SMS-модем, например Moxa 
Oncell G2xxx, к COM-порту сервера MXview. Выполните следующие действия, чтобы настроить 
отправку SMS-уведомлений: 
 

1. Зайдите в раздел Event -> Notification. 
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2. Нажмите Notification Settings. 

 
3. Перейдите на вкладку SMS. Выберите COM-порт, скорость передачи данных и режим 

сообщений, в котором работает модем, затем нажмите OK. 
4. Нажмите New в Action List. 
5. Выберите SMS в качестве типа уведомления, введите номер телефона, название действия 

и нажмите OK. 
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6. Нажмите New в Notification List. 
7. Выберите только что добавленное действие и соответствующий тип события, IP-адрес 

источника. 

 
8. Нажмите OK. 

 

Уведомление по Email 
 
Выполните следующие действия, чтобы настроить Email-сервера (SMTP) для отправки 
уведомления по Email: 
 

1. Зайдите в раздел Event -> Notification. 
2. Выберите Notification Settings. 
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3. Перейдите на вкладку Email. Введите SMTP-сервер, который может отправлять e-mail, а 

также имя пользователя и пароль, необходимые для входа на сервер, и нажмите OK. 
4. Нажмите New в Action List. 
5. Выберите Email в качестве типа уведомления, введите адрес электронной почты, название 

действия и нажмите OK. 

 
6. Нажмите New в Notification List. 
7. Выберите только что добавленное действие и соответствующий тип события, IP-адрес 

источника. 
8. Нажмите OK. 

 

Уведомление по SNMP Trap 
 
MXview может взаимодействовать с другим программным обеспечением для управления сетью и 
отправлять сообщения SNMP Trap сторонним NMS. MXview поддерживает до двух trap-серверов. 
Выполните следующие действия, чтобы настроить отправку сообщений SNMP Trap: 
 

1. Зайдите в раздел Event -> Notification. 
2. Выберите Notification Settings. 
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3. Перейдите на вкладку SNMP Trap. Введите версию SNMP и информацию о trap-сервере, 

нажмите OK. 
4. Нажмите New в Action List. 
5. Выберите SNMP Trap в качестве типа уведомления, введите название действия и нажмите 

OK. 

 
6. Нажмите New в Notification List. 
7. Выберите только что добавленное действие и соответствующий тип события, IP-адрес 

источника. 
8. Нажмите OK. 

 

Уведомление на мобильный телефон 
 
MXview может отправлять уведомления на мобильный телефон через Apple APNS или Google 
C2DM с помощью приложения MXview ToGo.  
 

1. Зайдите в раздел Event -> Notification. 
2. Выберите Notification Settings. 
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3. Когда откроется окно Actions, введите имя в строке Name и в строке type – Mobile Client. 
4. Нажмите Receiver, чтобы ввести адрес электронной почты как идентификатор. 
5. Нажмите OK. 

 
 

 
6. Нажмите New в Notification List. 
7. Выберите Notification Name, выберите Event Type, введите Source IP и нажмите Actions. 
8. Нажмите OK. 

 
Примечание 
Эта функция должна использоваться с мобильным приложением Moxa – Mxview ToGo. После 
ввода Email-адреса как идентификатора в MXview ToGo и подключения к серверу MXview вы 
сможете найти введенный Email в списке получателей. 
 
 
Примечание 
Использование Mobile Notification должно предоставить серверу MXview возможность 
подключения к Apple APNS или Google C2DM. Включите следующие исходящие порты в политике 
firewall: 
• Google: 5228, 5229, 5230  
• Apple: 443, 2194, 2195, 5223 
 
 
Примечание 
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Используйте следующие команды для просмотра соединений между сервером MXview и Apple 
APNS или GoogleC2DM: 
• telnet gcm.googleapis.com 5228 
• telnet gateway.sandbox.push.apple.com 443 
 
 
Примечание 
Сертификат Apple APNS следует продлевать каждый год. Пожалуйста, зайдите на сайт Moxa для 
получения последнего сертификата APNS. 
 

Звуковое уведомление 
 
Когда включено звуковое уведомление, сервер MXview будет воспроизводить заданный звуковой 
файл при возникновении события. Звук будет воспроизводиться несколько раз, пока пользователь 
вручную не остановит его. Выполните следующие действия, чтобы настроить звуковое 
уведомление: 
 

1. Зайдите в раздел Event -> Notification. 
2. Нажмите New в Action List. 
3. Выберите Sound в качестве типа, выберите файл с локального компьютера, укажите имя 

действия и нажмите OK. Файл будет загружен на сервер MXview. 

 
4. Нажмите New в Notification List. 
5. Выберите только что добавленное действие и соответствующий тип события, IP-адрес 

источника. 
6. Нажмите OK. 

 
Когда произойдет настроенное событие, воспроизведется звуковой файл и появится 
всплывающее окно: 

 
 
Звук не перестанет воспроизводиться, пока кто-нибудь вручную не остановит его. 
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Примечание 
Когда происходит более одного события, сначала воспроизводится звуковой файл, 
соответствующий первому событию, а звуки, соответствующие следующим событиям, будут 
поставлены в очередь. После того, как первый звук будет остановлен, воспроизведется 
следующий в очереди звук. 
 
 
Примечание 
Поддерживается только формат wav. 
 

Уведомление с помощью внешней программы 
 
Когда настроено уведомление с помощью внешней программы, сервер MXview запускает 
соответствующую программу. Выполните следующие действия, чтобы добавить программу: 
 

1. Зайдите в раздел Event -> Notification. 
2. Нажмите New в Action List. 
3. Выберите Program в качестве типа, выберите файл с локального компьютера, укажите имя 

действия и нажмите OK. Файл будет загружен на сервер MXview. 
4. Нажмите New в Notification List. 
5. Выберите только что добавленное действие и соответствующий тип события, IP-адрес 

источника. 
6. Нажмите OK. 

 
Когда произойдет настроенное событие, будет запущен файл программы. 
 

Уведомление в окне сообщений 
 
Когда настроено уведомление в окне сообщения, это окно будет отображаться на сервере 
MXview. Вы можете создать новое окно сообщения, выполнив следующие шаги: 
 

1. Зайдите в раздел Event -> Notification. 
2. Нажмите New в Action List. 
3. Выберите Message Box в качестве типа, укажите имя действия и нажмите OK.  
4. Нажмите New в Notification List. 
5. Выберите только что добавленное действие и соответствующий тип события, IP-адрес 

источника. 
6. Нажмите OK. 

 
Когда произойдет настроенное событие, система отобразит окно сообщений. 
 

Событие Syslog 
 
MXview может выступать в роли сервера событий Syslog с просмотром событий с помощью Syslog 
Event Viewer. Выполните следующие действия, чтобы использовать средство просмотра для 
проверки всех событий syslog: 
 

1. Зайдите в раздел Event -> Syslog Event Viewer. 
2. Введите условия фильтра (Filter Conditions). 
3. Нажмите Query. 
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Воспроизведение сетевых событий 
 
Всякий раз, когда MXview обнаруживает, что с устройством под его управлением происходит 
событие, например, разрыв соединения, MXview обновляет состояние устройства на карте 
топологии. Более того, MXview ведет учет изменений состояния в базе данных сроком до 30 дней 
и предоставляет интерфейс, который позволяет пользователям смотреть прошлые события и 
проверить состояние сети за прошедшие 30 дней. 
 

Включение режима воспроизведения 
 
По умолчанию режим воспроизведения отключен. Чтобы включить его, 
 

1. Зайдите в раздел Project -> Preferences. 
2. Нажмите System Configuration, выберите для параметра Playback значение Enable. 
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Вход в режим воспроизведения 
 
Чтобы войти в режим воспроизведения, выберите в качестве режима работы Playback на 
стартовой странице.  

 
 

Режим времени и режим события 
 
Существует два режима воспроизведения событий. В режиме времени (time mode) MXview 
посекундно будет воспроизводить события на карте топологии. В режиме событий (event mode) 
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MXview будет воспроизводить событие за событием. Пользователи могут выбирать скорости 
воспроизведения от 1X до 16X. 
 

Обзор пользовательского интерфейса воспроизведения 
 

 
 

• Topology map – Карта топологии 
Карта топологии отображает состояние сети в определенный момент времени, указанный в 
индикаторе времени. 

• Event List and All Event button – Список событий и кнопка «Все события» 
В этом окне отображаются события, соседствующие с текущим отображаемым событием. 
Выделяется самое последнее событие. Нажмите кнопку All Events для доступа к окну поиска всех 
событий с фильтрами. В отфильтрованных результатах вы можете щелкнуть по фильтруемому 
событию, чтобы перейти прямо к его воспроизведению. 

• Control panel – Панель управления 
Панель управления включает в себя индикатор времени, ползунок времени и календарь, которые 
соответствуют сети, отображаемой в указанное время на карте топологии. 
 
Пользователи могут перейти к моменту времени, который они хотели бы проверить. Ползунок 
можно двигать по 24 часам выбранной даты. Чтобы изменить дату, пользователи могут нажать на 
календарь и выбрать другую. 
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10) Отчеты о трафике 
 
 
 
MXview собирает статистику трафика со всех устройств, работающих в сети. Статистика 
используется для создания отчетов, показывающих использование канала и загруженность 
интерфейсов устройств. Статистика выполняется для следующих элементов: 
 

• Использование канала (%) 
• Процент ошибочных пакетов (%) 

 
События будут создаваться, когда один из этих элементов находится выше или ниже 
соответствующих пороговых значений. 
 

Проверка тренда 
 
Прежде чем MXview сможет собирать статистику трафика между двумя устройствами, 
необходимо создать линию связи (см. Раздел “Adding a Link” в главе 8, чтобы узнать, как добавить 
линию связи). 
 
Щелкните правой кнопкой мыши по линии связи, выберите Link Traffic, затем режим мониторинга 
Port Traffic или Packet Error Rate.  
 

 
 
В режиме Port Traffic график показывает процент загрузки канала на определенный период 
времени. Пользователь может определить свой период времени в верхнем правом углу окна. 
Минимальный промежуток времени – один день. 
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Масштаб оси Y (в процентах) настраивается и соответствует 4 десятичным знакам. Чтобы изменить 
масштаб оси Y, просто прокрутите колесо мышки вниз или вверх. Независимо от того, на какой 
масштаб вы ее измените, всегда можно нажать Default Size, чтобы восстановить масштаб графика 
до исходной настройки. 
 
Представленные здесь данные могут быть экспортированы. В нижней части окна можно 
экспортировать график в виде PNG-файла или данные в виде CSV-файла. 
 
Интерфейсы для мониторинга Packet Error Rate и Port traffic идентичны. 
 

Уведомления о пороговых значениях и событиях 
 
Ниже описаны условия трафика, которые могут вызывать события: 
 

1. Загрузка канала превышает пороговое значение 
2. Загрузка канала ниже порогового значения 
3. Процент ошибочных пакетов превышает порог 

 
Поскольку линия связи двунаправленна, событие будет создано, когда одно из направлений 
соответствует условиям настроенного события. 
 
Чтобы узнать, как изменить пороговое значение, обратитесь к разделу Способы мониторинга -> 
Уровень угрозы в главе 9, События и уведомления. 
 
Чтобы узнать, как настроить уведомления, обратитесь к разделу Способы мониторинга -> 
Уведомления в главе 9, События и уведомления.  
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11) Управление устройствами 
 
 
 
 
В данной главе рассмотрены следующие темы: 
 
 Свойства устройства 
 Виртуальная панель устройства 
 Изменение свойств устройства 
 Выбрать иконку 
 Вход в web-консоль 
 Интерфейс управления 
 Резервное копирование и восстановление настроек (только для устройств Moxa) 
 Обновление прошивки 
 Обновление состояния устройства 
 Массовый экспорт/импорт настроек устройств и обновление прошивок 

 Экспорт настроек с нескольких устройств 
 Импорт настроек нескольких устройств 
 Обновление прошивки нескольких устройств 
 Экспорт/импорт настроек по расписанию 
 История изменений и сравнение настроек  

 Отчет о доступности устройства и его состоянии 
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Свойства устройства 
 
MXview предлагает три способа просмотра свойств устройства: 
 

1. Раздел Device Property в основном окне. 
(см. раздел Свойства устройства в главе 6, Обзор приборной панели) 

2. Быстрый просмотр свойств устройства 
Щелкните правой кнопкой мыши на устройстве на главной странице и выберите property. 
Вы можете выбрать устройство и щелкнуть правой кнопкой мыши по нему. Здесь отображаются 
следующие свойства: название модели, MAC-адрес, IP-адрес, маска сети, шлюз, тип и состояние 
порта, состояние питания, протокол резервирования, доступность по SNMP- и ICMP- протоколу. 

3. Настраиваемые свойства устройства 
В меню зайдите в Information -> Device Property. 
Device Property – это настраиваемая таблица для просмотра свойств устройств сети. В верхней 
части окна – редактируемые опциональные свойства – IP, Alias, Property и Value. 
Выбрав раскрывающееся меню для каждого элемента свойств, вы можете отфильтровать 
определенные элементы, которые вы хотите отобразить. 
Элемент property имеет то же свойство, что и inventory report (см. раздел Отчет об устройстве и 
его состоянии в главе 11, Управление устройствами). В результате вы можете использовать 
свойство устройства для фильтрации всех устройств с определенным свойством. 
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Окно Device Property можно экспортировать в CSV-файл. Для этого просто нажмите кнопку Export 
to CSV. 
 

Виртуальная панель устройства 
 
MXview может отображать переднюю панель коммутаторов Moxa и активное состояние их портов 
со светодиодными индикаторами: 
 
Щелкните правой кнопкой мыши на устройстве и выберите Panel 
 

 
 

Изменение свойств устройства 
 
Выполните следующие шаги, чтобы изменить местоположение устройства, его имя, контакт, IP-
адрес, маску сети, шлюз, trap-сервер и настройки SNMP: 
 

1. Выберите устройство. 
2. Зайдите в Device -> Maintenance -> Configure IP & Trap. 

 
Перейдите на вкладку Basic, чтобы изменить имя, местоположение и контактную информацию 
устройства. 
 
Перейдите на вкладку IP Configuration, чтобы изменить IP-адрес устройства, маску сети, шлюз, 
DNS-сервер и способ получения IP-адреса. 
 
Перейдите на вкладку Trap Server, чтобы изменить IP-адреса и строки community string trap-
серверов. Коммутаторы Moxa могут отправлять trap-сообщения не более, чем на 2 trap-сервера.  
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Выбрать иконку 
 
MXview позволяет пользователям вручную менять иконку устройства. Выполните следующие 
действия, чтобы выбрать значок устройства из базы значков MXview. 
 

1. Выберите устройство. 
2. Зайдите в Device -> Maintenance -> Assign model. 

 
Появится окно Assign Model. Выберите модель коммутатора из раскрывающегося списка и 
нажмите кнопку Assign, чтобы подтвердить свой выбор. 
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Вход в web-консоль 
 
Чтобы войти в web-консоль устройства, выберите Device -> console.  
 
Примечание 
Для IE6 MXview откроет консоль в окне MXview Client. 
 

Интерфейс управления 
 

1. Зайдите в Project -> Preferences -> Management Interface. 
2. Протокол web-консоли может быть настроен как HTTP или HTTPS, после чего номера 

портов HTTP и HTTPS могут быть установлены пользователями. Кроме того, там же можно 
установить Telnet-порт. 
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Резервное копирование и восстановление настроек 
(только для устройств Moxa) 
 
Выполните следующие действия для резервного копирования файла настроек устройства на 
локальный компьютер: 
 

1. Зайдите в Device -> Maintenance -> Configuration -> Load from Device. 
2. Выберите место, куда вы хотите сохранить файл. 

 
Для восстановления файла настроек выполните следующие действия: 
 

1. Зайдите в Device -> Configuration -> Load to Device. 

 
2. Выберите файл и нажмите OK. 

 

Обновление прошивки 
 
Чтобы обновить прошивку устройства, зайдите в Device -> Firmware Upgrade. Прошивка будет 
загружена и установлена на устройство. 
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Примечание 
После успешной установки прошивки устройство перезагрузится. Это может занять несколько 
секунд. 
 

Обновление состояния устройства 
 
Поскольку некоторые данные устройства собираются путем опроса, для передачи некоторых 
данных может возникнуть задержка передачи. Чтобы обновить устройство для получения его 
обновленного статуса, выберите Device -> Refresh. 
 

Массовый экспорт/импорт настроек устройств и 
обновление прошивок 
 
MXview позволяет пользователям экспортировать/импортировать настройки и обновлять 
прошивку сразу целой группы устройств. 
 

Экспорт настроек с нескольких устройств 
 

1. Зайдите в Tools -> Configuration Center 
 

 
 

2. Нажмите Export from Device 
3. Выберите папку для сохранения файлов настроек 
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4. Выберите устройства для экспорта файлов настроек и добавьте их в список. Нажмите 
Export 

 

 
 
В течение нескольких секунд файлы настроек будут экспортированы в указанную папку с IP-
адресами и отметками времени в именах файлов. 
 

Импорт настроек нескольких устройств 
 
Коммутаторы Moxa могут импортировать конфигурационные файлы и изменять настройки 
устройств на основе параметров, описываемых файлом. MXview помогает пользователям 
импортировать конфигурационные файлы на несколько устройств. 
 

1. Зайдите в Tools -> Configuration Center 
2. Выберите Import to Device 
3. Выберите конфигурационный файл 
4. Выберите устройства для импорта конфигурационного файла и добавьте их в список. 

Нажмите Import 
 
В течение нескольких секунд файлы настроек будут импортированы на устройства и 
активированы. 
 

Обновление прошивки нескольких устройств 
 

1. Зайдите в раздел Information -> Firmware Version 
2. Нажмите Upgrade 
3. Выберите файл прошивки 
4. Выберите устройства, на который нужно загрузить прошивку и добавьте их в список. 

Нажмите Upgrade 
 
В течение нескольких секунд прошивка последовательно обновится на всех устройствах. MXview 
ждет 30 секунд прежде, чем обновлять следующее устройство в списке, чтобы предоставить 
обновляющим устройствам достаточно времени для завершения процесса. 
 

http://www.moxa.ru/
mailto:sales@moxa.ru
mailto:support@moxa.ru


MXview: Руководство пользователя 
 

www.moxa.ru                                                         sales@moxa.ru                                         support@moxa.ru 

Экспорт/импорт настроек по расписанию 
 

1. Зайдите в раздел Tools -> Job Scheduler 
 

 
 

2. Нажмите Add 
3. Введите имя задания и выберите Import Configuration, Export Configuration или Database 

Backup в раскрывающемся списке. 
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4. Выберите устройства, к которым нужно применить настройку, и добавьте их в список. 
Нажмите Next 

5. Выберите процедуру выполнения. 
 

История изменений и сравнение настроек  
 
Когда MXview экспортирует настройки с устройств, вручную или по расписанию, MXview будет 
сравнивать экспортированную конфигурацию с последней экспортированной и сохраненной на 
сервере MXview. Если есть отличия, MXview сохранит конфигурацию на сервере MXview. 
Пользователи могут проверять историю изменений файла конфигурации: 
 

1. Зайдите в Tools -> Configuration Center 
2. Выберите List of Configurations 

 
Пользователи могут сравнивать любые 2 сохраненные конфигурации на сервере MXview 
 

1. Зайдите в Tools -> Configuration Center 
2. Выберите Compare 
3. Выберите 2 IP-адреса и их настройки 
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Добавленные, удаленные и измененные строки в настройках будут выделены. 
 

Отчет о доступности устройства и его состоянии 
 
MXview может объединять информацию об устройстве в официальном отчете. Доступны 
следующие отчеты: Device Availability Report (отчет о доступности устройства) и Inventory Report 
(отчет о состоянии устройства). 
 
Device Availability Report (отчет о доступности устройства) 
 
Отчет о доступности устройства включает информацию об IP-адресе, имени устройства, времени 
доступности и данных о прогнозируемой доступности. Вы можете сузить отчет на определенный 
период времени по датам и группам. 
 
Выберите Information -> Availability Report 
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Отчет о доступности можно экспортировать в файл PDF или CSV. 
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По умолчанию доступность рассчитывается на основе 24-часовых интервалов. Чтобы изменить 
это, в меню выберите Project -> Preferences -> Advanced -> Devices -> Timeframe for availability 
calculation. 
 
Введите промежуток времени в поле и нажмите OK. Единица измерения – час. 
 
Inventory Report (отчет о состоянии устройства) 
 
Выберите Information -> Inventory Report для создания отчета о состоянии устройств. 
 
В отчете содержится сводка свойств каждого устройства. С отчетом Inventory Report MXview будет 
экспортировать отчеты для всех устройств сети отдельно друг от друга. У каждого устройства 
будет отдельный PDF-отчет. Имя PDF-файла определяется IP-адресом устройства. Заголовок отчета 
– это имя устройства, которое пользователи могут редактировать в MXview. Если в MIB-базе 
имеются сторонние MIB-данные, эта информация будет включена в отчет (см. главу 13 – MIB). 
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12) Режим визуализации 
 
 
 
В данной главе рассмотрены следующие темы: 
 
 Визуализация VLAN-сетей 
 Визуализация IGMP Snooping 
 Визуализация загрузки канала 
 Уровни безопасности 
 Приборная панель беспроводных устройств 
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Визуализация VLAN-сетей 
 
Коммутаторы Moxa поддерживают стандарт 802.1Q с метками VLAN. MXview собирает настройки 
VLAN с каждого устройства и визуально представляет информацию с цветовыми пометками, 
чтобы дать пользователю представление о всей сети. 
 

1. Нажмите на иконку VLAN на строке инструментов топологии 

 
2. После выбора VLAN ID, устройства, порты и линии связи, связанные с этим VLAN ID, будут 

помечены определенным цветом. 
 
Чтобы просмотреть информацию о VLAN-сети в формате таблицы, выберите Network -> VLAN. 
 

 
 

Визуализация IGMP Snooping 
 
Коммутаторы Moxa поддерживают технологию IGMP snooping. MXview собирает конфигурацию 
IGMP snooping каждого устройства и визуализирует информацию, чтобы дать пользователю 
представление обо всей сети. 
 

1. Нажмите на иконку VLAN на строке инструментов топологии 

 
2. После выбора VLAN ID и multicast-адреса, устройства, порты и линии связи, связанные с 

данным потоком, будут помечены определенным цветом. 
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Визуализация загрузки канала 
 
MXview собирает информацию о загрузке трафиком каждой линии связи и отображает 
информацию, чтобы дать пользователю общее представление. 
 

1. Нажмите на иконку Traffic Load на строке инструментов топологии 

 
2. Откроется окно Traffic Load. Оно использует разные цвета для отображения разных 

уровней нагрузки. 
 

 
 

3. Все линии связи будут иметь цветовую маркировку, чтобы показать, сколько трафика они 
проводят. 

 

 
 

4. Зайдите в Project -> Preferences -> Appearance для перераспределения уровней нагрузки 
на трафик. 

 

http://www.moxa.ru/
mailto:sales@moxa.ru
mailto:support@moxa.ru


MXview: Руководство пользователя 
 

www.moxa.ru                                                         sales@moxa.ru                                         support@moxa.ru 

 
 

Уровни безопасности 
 
ISA/IEC 62443 – это постоянно развивающийся стандарт кибербезопасности, рекомендации 
которого уже приняты во многих системах промышленной автоматизации. Этот стандарт, включая 
его подразделы, рассматривает такие вопросы, как общие требования безопасности, политика и 
процедуры, требования к уровню безопасности системы и требования к уровню безопасности 
компонентов. 
 
MXview от компании Moxa следует текущим рекомендациям по безопасности стандарта IEC 
62443-4-2. Функция Security View проверяет уровень безопасности сетевых устройств Moxa. 
Существует пять уровней проверки результатов Security View: 
 
 High: IEC 62443-4-2 level 2 – высокий  
 Medium: IEC 62443-4-2 level 1 – средний 
 Basic: Базовый уровень 
 Open: Уровень безопасности ниже базового 
 Unknown: Устройства без информации об уровне безопасности для MXview 

 
Примечание 
Определение базового уровня основано на типовых политиках и потребностях в области 
кибербезопасности. 
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1. Нажмите на иконку Security View на строке инструментов топологии 

 
2. Откроется окно Security View. Здесь также используются разные цвета для отображения 

разных уровней безопасности, каждое устройство имеет маркировку. 
 

 
 

3. Пользователи могут видеть в этом окне пункты Check Items и Current Settings. Буквы H, M, B 
означают уровни High, Medium и Basic соответственно.  указывает, что указанный 
элемент успешно настроен,   – что указанный элемент не соответствует этому уровню, а 
пустой – что указанный элемент еще не был настроен. 

 

 
 

4. Используя фильтр (Filter), пользователи могут выбирать устройства с определенным 
уровнем безопасности. 
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5. Нажмите Export, чтобы экспортировать информацию об IP-адресах устройств, элементах 
безопасности и текущих настройках в CSV-файл. 

 

 
 

6. Нажмите Launch MXconfig для активации MXconfig для групповой настройки параметров 
безопасности. В MXconfig Security Wizard можно указать все параметры, относящиеся к 
различным уровням безопасности, чтобы пользователи могли легко ввести свою 
информацию для групповой настройки. 
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Примечание 
Подробная информация о MXconfig Security Wizard – в HELP-файле MXconfig. 
 

7. Зайдите в Project -> Preferences -> Security View для перераспределения цветов различных 
уровней безопасности. Пользователи также могут определить свой собственный уровень 
безопасности, выбрав User-defined Profile. Все элементы проверки могут быть установлены 
для Security View, и для проверенных результатов отобразятся как Pass (соответствует 
уровню) или Not Pass (не соответствует уровню). 
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Ниже приводится подробное описание каждого элемента: 
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 Enable Auto Logout: Включает функцию автоматического выхода пользователя из системы 
 Set Login Message: Устанавливает сообщение для входа в систему 
 Disable Non-encrypted TCP/UDP Ports: Отключены незашифрованные порты TCP/UDP или 

нет 
 Enable Account Login Failure Lockout: Включена функция блокировки входа в учетную 

запись или нет 
 Enable Trusted Access: Включена функция Trusted Access или нет 
 Enable Password Complexity Strength Check: Включена функция проверки сложности 

пароля или нет 
 Enable Configuration File Encryption: Включена функция шифрования конфигурационного 

файла или нет 
 Enable Broadcast Storm Protection: Включена защита от широковещательного шторма, 

Broadcast Storm Protection, или нет 
 Set SNMP Trap/Inform or Syslog Server: Установлен SNMP Trap/Inform или Syslog-сервер или 

нет. 
 Change Default Password/SNMP Community String: Установлены пароль по умолчанию или 

SNMP Community String или нет  
 

Приборная панель беспроводных устройств 
 
MXview собирает информацию о беспроводной сети со всех устройств Moxa серии AWK и 
отображает информацию на приборной панели мониторинга беспроводных устройств – Wireless 
Dashboard. 
 

1. Зайдите в раздел Information -> Wireless Dashboard для активации приборной панели 
беспроводных устройств. 

2. Здесь перечислены все точки доступа (AP) и клиенты. Имя устройства, IP-адрес, MAC-
адрес, мощность сигнала и SNR отображаются на приборной панели. Кроме того, также на 
панели управления может отображаться связь между точками доступа и клиентами. 

 

 
 

3. Нажав на значок , пользователи могут установить пороговое значение для мощности 
сигнала и SNR. Могут быть установлены различные цвета для индикации на приборной 
панели. 
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Примечание 
Только устройства серий AWK-1131A, AWK-3131A и AWK-4131A поддерживают приборную панель 
Wireless Dashboard. 
 
 
Примечание 
Приборная панель автоматически обновляется каждые 15 секунд. 
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13) MIB 
 
 
 
 
Встроенный компилятор MIB MXview поддерживает сторонние MIB-файлы. После компиляции 
MIB-файла в MXview можно контролировать любой параметр устройства. 
 
В данной главе рассмотрены следующие прикладные инструменты компилятора MIB: 
 
 MIB Browser 
 OID Import Manager 
 Trap Import Manager 
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MIB Browser 
 
MIB browser обеспечивает удобный интерфейс просмотра собственных параметров MIB-файлов. 
OID import manager делает все контролируемые параметры настраиваемыми, чтобы их можно 
было прочитать в окне списка свойств устройства. С помощью Trap Import Manager в окне истории 
событий могут отображаться сторонние trap-сообщения. 
 
MIB Browser – это простой интерфейс, позволяющий просматривать MIB-файлы. Он может 
загружать сторонние MIB-файлы. После загрузки MIB-файлов дерево переменных OID появится в 
столбце слева. Пользователь может развернуть это дерево OID и увидеть необходимый параметр. 
 
Чтобы открыть MIB Browser, зайдите в MIB -> MIB Browser 
 

 
 
 Нажмите File -> Load MIB для загрузки MIB-файла 
 Выберите элемент в дереве MIB 
 Нажмите Get, чтобы увидеть параметр выбранного элемента 
 Нажмите Get Next, чтобы получить переменные OID рядом с выбранным элементом 
 Нажмите Get Subtree, чтобы получить все переменные OID в папке поддерева 
 Нажмите Walk, чтобы последовательно получить параметры переменных OID 
 Нажмите Set, чтобы настроить параметры выбранной переменной OID 

 

OID Import Manager 
 
OID Import manager помогает добавлять определенные элементы переменных OID для опроса по 
SNMP-протоколу. Он поддерживает опрос сторонних MIB-файлов. После компиляции MIB-файлов 
пользователь может отслеживать переменные OID сторонних производителей с помощью опроса 
по SNMP. 
 
Чтобы открыть Import manager, зайдите в MIB -> OID Import Manager 
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 Список List of Polling OIDs перечисляет все элементы опроса 
 Нажмите Show Details, чтобы увидеть имя OID, OID и все устройства, которым назначена 

эта переменная OID 
 Нажмите Add, чтобы добавить переменную OID из стандартного или стороннего MIB-

файла  
 Нажмите Modify, чтобы изменить имя импортированной переменной OID 
 Нажмите Delete, чтобы удалить импортированную переменную OID 

 
Есть два шага для добавления новой переменной OID и назначения ее конкретному устройству. 
 

1. Добавить конкретную переменную OID 
Нажмите Add, чтобы добавить новую OID для опроса. Откроется окно. Вы можете импортировать 
MIB-файлы, выбрав File -> Load MIB. В этом окне вы можете редактировать имя (Name) для 
выбранной OID. Это имя будет отображаться в окне свойств устройства. 
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Нажмите кнопку Test, чтобы сначала попытаться получить параметр OID. Вы можете найти 
описание этого OID в окне OID description. Нажмите кнопку Add, чтобы добавить эту переменную 
OID в диспетчер импорта. 
 

2. Назначить опрашиваемый OID устройству 
 
Нажмите кнопку Assign в OID import manager. Откроется окно Assign Polled Devices. 
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В этом окне будут перечислены все устройства сети. Выберите устройство, которое вы хотите 
назначить, затем нажмите Add. Выбранное устройство будет перемещено вправо. После выбора 
устройства нажмите Assign для завершения. 
 
После добавления устройства нажмите на него на главном экране. Переменная OID MIB-файла 
устройства стороннего производителя можно прочитать в окне свойств устройства.  
 

 
 

Trap Import Manager 
 
Trap Import Manager может читать MIB-файлы устройств сторонних производителей и 
компилировать их в MXview. 
 
Чтобы открыть trap import manager, зайдите в MIB -> Trap Import Manager 
 

 
 
 В столбце list of traps перечислены все импортированные trap-сообщения 
 Нажмите Show Details, чтобы прочитать подробную информацию, включая имя trap, 

переменную OID и ее описания 
 Нажмите Import для загрузки MIB-файлов и выбора trap для импорта 
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 Нажмите Modify Description, чтобы назначить описание Trap. Созданное здесь описание 
будет событием trap, которое отобразится в списке событий 

 Нажмите Delete, чтобы удалить импортированный trap 
 
Для добавления нового Trap в MXview есть три шага. 
 

1. Загрузите MIB-файл 
Нажмите на кнопку Import. Откроется окно Import Dialog. Затем нажмите Load MIB и выберите 
MIB-файл для загрузки. 
 
После загрузки MIB-файла нажмите Parse. В столбце справа перечислены все trap-сообщения. 
 

 
 

2. Выберите Trap-сообщение для импорта 
Установите флажок, соответствующий Trap-сообщению, которое вы хотите импортировать. 
Нажмите кнопку за каждым Trap, чтобы показать его переменную OID и исходное описание его в 
MIB-файле. 
 

 
 

3. Редактировать описание 
В списке Trap поле описания доступно для редактирования. Вы можете написать здесь 
индивидуальное описание. 
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По завершении нажмите кнопку Import. Диалоговое окно будет закрыто, вы вернетесь в окно Trap 
Import Manager. Вы найдете импортированные trap в своем списке. 
 

 
 
Примечание 
Система выдаст всплывающее окно, если OID уже импортирована. 
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14) Лицензия MXview 
 
 
 
 
Программное обеспечение MXview доступно в разных версиях, в каждой из которых 
поддерживаются разное количество узлов. Например, если ваша версия MXview поддерживает 
250 узлов, то при обнаружении устройств MXview распознает максимум 250 узлов. MXview 
остановит процедуру поиска устройств после достижения предела в 250 узлов. 
 

Проверка лицензии 
 
Количество управляемых узлов и ограничение версии указано в строке состояния на панели 
управления. 
 

 
 
Подробнее – Help -> License 
 

 
 

Обновление лицензии 
 
Чтобы увеличить лимит устройств вашего MXview, вам необходимо обновить лицензию.  
 

1. Выберите Help -> License. 
2. Нажмите Add License. 

 

 
 

3. Найдите лицензионный ключ в программном пакете, который отображается как: 
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4. Введите ключ новой лицензии и нажмите OK. 

 

 
 

5. Перезапустите клиент MXview. 
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Приложение A: FAQ 
 
 
 
Почему события появляются с опозданием? 
Убедитесь, что вы настроили сервер SNMP trap коммутатора на IP-адрес сервера MXview, так как 
это обеспечит оповещение о событиях в режиме реального времени. В противном случае MXview 
будет собирать информацию не мгновенно, а с определенным периодом опроса. 
 
Почему я не могу обнаружить все устройства в своей сети? 
Проверьте следующее: 
 

1. Убедитесь, что ваша лицензия поддерживает достаточное количество узлов. 
2. Убедитесь, что диапазон сканирования включает все IP-адреса устройств в вашей сети. 
3. Убедитесь, что ваши коммутаторы не входят в режим защиты, protection mode, потому что 

считают, что пакеты MXview являются частью широковещательного шторма. 
 
Почему одно устройство имеет больше одной иконки? 
MXview идентифицирует устройства по IP-адресу. По этой причине, если одно устройство имеет 
более одного IP-адреса в пределах диапазона сканирования, оно будет рассматриваться как 
несколько устройств. 
 
Если удалить ли линию связи в MXview, отключится ли линия связи в реальной сети? 
Нет. Карта топологии показывает состояние реальной сети, но не может использоваться для 
настройки реальной сети. 
 
После того, как связь в кольце отключена, почему нужно несколько секунд, чтобы 
резервная линия связи стала сплошной линией на карте топологии? 
MXview использует механизм опроса, чтобы определить, не стали ли резервные линии связи 
основными. По этой причине карта топологии не будет обновлена до тех пор, пока не будут 
опрошены все устройства сети. Кроме того, поскольку для передачи состояния сети на сервер 
MXview требуется некоторое временя, для обновления карты топологии потребуется не меньше 
времени. 
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